Java Upgrade from 5 to 8

I am working on a legacy application which is still running on JDK5. As part of our new requirement we need to update it to JDK 8. As per my understanding since Java is backward compatible, this should have worked. When I compiled with JDK 8 , the build was successful. But while launching ,I got the following error :

Error creating bean with name 'AuthorisationDialogController' defined in class path resource [com/some/application/conf/dispense/dispense-controllers.xml]: Error setting property values; nested exception is org.springframework.beans.PropertyAccessExceptionsException: PropertyAccessExceptionsException (1 errors); nested propertyAccessExceptions are: [org.springframework.beans.TypeMismatchException: Failed to convert property...

Read More »

By: StackOverFlow - 6 days ago

Related Posts